Back to overview
Downtime

Voxeus API is down

Mar 11 at 05:30pm CET
Affected services
Voxeus

Resolved
Mar 12 at 10:39am CET

Voxeus authentication is now fixed.

Created
Mar 11 at 05:30pm CET

Voxeus authentication system is down.
We are currently working on using another system.